autoconf/automake/libtool trouble (bad version?)

Alexander E. Patrakov semzx at newmail.ru
Sat Jan 10 03:28:43 PST 2004


On my computer, the following versions are installed:

autoconf (GNU Autoconf) 2.59
automake (GNU automake) 1.7.8
ltmain.sh (GNU libtool) 1.5 (1.1220 2003/04/05 19:32:58)

The trouble is that at least one ./configure script generated by these
autotools fails to guess the correct shared library extension. To
reproduce the problem, install the following packages from BLFS as the
instructions say: libjpeg, libpng, freetype (and maybe XFree86). Then
download the gd graphics library, version 2.0.15 or 2.0.19. I hit the
bug when trying to patch in the support for GIF files, but that's
irrelevant. The procedure to reproduce the bug is outlined below.

1) The case without this bug - autoconf is not used

tar zxf gd-2.0.19.tar.gz    # (2.0.15 also has the problem)
cd gd-2.0.19
./configure --prefix=/usr
make
ls .libs

You will see the libgd.so symlink pointing to libgd.so.2.0.0. So far so
good.

2) The case with a bug - autoconf used

tar zxf gd-2.0.19.tar.gz    # (2.0.15 also has the problem)
cd gd-2.0.19
# Here I tried patching in GIF support, let's skip this patch.
# After patching, autotools should regenerate the ./configure script
# Let's do it, although we skipped the patch.
autoheader
aclocal
autoconf
automake
./configure --prefix=/usr
make
ls .libs

You will see the libgd symlink pointing to libgd.2.0.0 (no .so extension).

3) The problem is fixed if I run libtoolize --force before ./configure,
thus upgrading the included libtool from 1.4.3 to 1.5.

The problem also exists in an older LFS-4.1 installation.

I am not an autotools expert. How should I diagnose whether the problem
is in LFS or on the gd author's computer?

-- 
Alexander E. Patrakov










More information about the lfs-support mailing list