grep 2.5 configure error

Matthias Güntert MatzeGuentert at gmx.de
Fri Jan 9 10:13:40 PST 2004


Matthias Güntert wrote:
> Hello
> 
> Due the unavailabilty of grep 2.5.1 i have tried compiling grep 2.5
> 
> ./configure --prefix=/usr --bindir=/bin --with-included-regex results in
> 
> config.status: creating config.h
> ./config.status: line 789: egrep: command not found
> config.status: executing default-1 commands
> ./config.status: line 919: grep: command not found
> ./config.status: line 919: grep: command not found
> ./config.status: line 919: grep: command not found
> ./config.status: line 919: grep: command not found
> ./config.status: line 919: grep: command not found
> ./config.status: line 919: grep: command not found
> ./config.status: line 919: grep: command not found
> ./config.status: line 919: grep: command not found
> ./config.status: line 919: grep: command not found
> ./config.status: line 919: grep: command not found
> config.status: executing default-2 commands
> config.status: creating po/POTFILES
> config.status: creating po/Makefile
> config.status: executing default commands
> root:/sources/grep-2.5#
> 
> for not wasting my little patience i have tried 2.4
> and again:
> 
> ./configure --prefix=/usr --bindir=/bin --with-include-regex
> 
> updating cache ./config.cache
> creating ./config.status
> ./configure: line 1: grep: command not found
> creating Makefile
> creating src/Makefile
> creating tests/Makefile
> creating po/Makefile.in
> creating intl/Makefile
> creating doc/Makefile
> creating m4/Makefile
> creating djgpp/Makefile
> creating vms/Makefile
> creating bootstrap/Makefile
> creating config.h
> root:/sources/grep-2.4#
> 
> make stops with:
> 
> gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../intl 
> -DLOCALEDIR=\"/usr/share/locale\"    -g -c grep.c
> In file included from grep.c:34:
> system.h:51: error: conflicting types for `sys_errlist'
> /usr/include/bits/sys_errlist.h:28: error: previous declaration of 
> `sys_errlist'
> grep.c: In function `main':
> grep.c:1391: error: `VERSION' undeclared (first use in this function)
> grep.c:1391: error: (Each undeclared identifier is reported only once
> grep.c:1391: error: for each function it appears in.)
> make[2]: *** [grep.o] Error 1
> make[2]: Leaving directory `/sources/grep-2.4/src'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/sources/grep-2.4'
> make: *** [all-recursive-am] Error 2
> root:/sources/grep-2.4#
> 
> Maybee someone can help me out? I had also a look at the Appendix for 
> alternative download locations, unfortunately without success. Someone 
> knows a link where to get grep-2.5.1?
> 
> Greets
> 
> 
> M. Güntert
> 
> 
> 
> 
> 

Ups sorry, forgot to mention that i have created my lfs with lfs-book 
version 5...




More information about the lfs-support mailing list