Problem with binutils-2.14 LFS 5.0

Dogggeti at aol.com Dogggeti at aol.com
Tue Jan 6 11:31:55 PST 2004


>>When I run the configure it creates the cache, checks the 
>>host, traget and build system type then errors:
>>../binutils-2.14/configure: line 2206: cc: command not found
>>*** The command 'cc -o conftest -g conftest.c' failed.
>>*** You must set CC to a working complier (paraphrased here)
>>
>>Well the book says I have to unset some variable, one of
>>which was CC.
>>
>>What should this be set to, or is there something else going on?
> 
> 
> It shouldn't be set to anything (hence the unset instruction).  Did you
> make the cc -> gcc link in the gcc instructions?
> 
>> I haven't even gotten to that point yet so the ln to the 
>> tools dir isn't possible right now. I think I've found the 
>> cause though: no gcc installed. I'm doing a quick upgrade on 
>> the system to install all the required packages and will see 
>> how the LFS build goes then. One of the problem with taking 
>> a system you not touched in about 4 months as a starting 
>> point is that you might not remember what you put on it!
>>
>> thanks.


i have exactly the same problem but my situation is still worse. i installed 
SuSE linux LiveEval and the installation worked. i was happy because this was 
my first contact with linux and i already was successfully installing it. but 
i still had no idea how linux actually worked. then i found LFS and thought 
this would be perfect to really learn linux
. now i sit in front of bash and get this error and dont know what to do.
what is this gcc you are talking about?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20040106/bc04626e/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Papyrus.jpg
Type: image/jpeg
Size: 4522 bytes
Desc: not available
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20040106/bc04626e/attachment.jpg>


More information about the lfs-support mailing list