Gcc/Glibc bug?

Gabriel Munoz munozga at uwec.edu
Thu Jan 1 10:25:28 PST 2004


On Thu, Jan 01, 2004 at 05:33:17PM -0600, mwright at acad.stedwards.edu wrote:
<snip>

> Can anyone reproduce this? Has anyone experienced this before? Is it
> peculiar to LFS? I tried to reproduce it on a non-LFS system and
> couldn't. Then again, it wouldn't core dump there, either.

I could reproduce this on a system built from cvs-20031011, which is pre
LFS-5.0 (5.0 released on Nov 5th 2003), with same error output (both
when using 0 and 1 as you mentioned).

I also tested this on my brand new system running CVS-20031217 nptl
enabled (Glibc-2.3-20031221, HJL-binutils-2.14.90.0.7, GCC-3.3.2) and I
recieved the expected segfault.

> If it's not LFS-specific, I assume I need to submit a bug report to Gcc
> or Glibc, but I'd like to know which one most likely has the problem (or
> if it's a problem in something else like Binutils that's causing it).

If it was indeed a bug in one of those packages it could have been fixed
in newer packages as I cannont reproduce it with a newer system.

I also completed my builds with all expected output from the checks.

Hope this helps a bit.

-- 
http://blackhole.cs.uwec.edu/~munozga/
Gabriel Munoz
--



More information about the lfs-support mailing list