BLFS-5.0 : Nautilus-2.2.4 installation error.

randhir phagura rsphagura at hotmail.com
Sun Feb 29 21:30:43 PST 2004


Hi,

I am new to LFS/BLFS. Having successfully installed LFS-5.1-Pre, I have gone 
on to installing BLFS-5.0.
Earlier, I had completed one install of BLFS-5 with LFS-5 and KDE as the 
preferred Desktop. Now, on LFS-5.1-Pre, I was trying to install GNOME as the 
preferred one. I have an i686-pc system with 256 MB memeory. I have been 
able to install upto GNOME Desktop package, with all the relevent 
dependencies. After installing 'metacity', I was installing 'nautilus' 
file-manager when this error occured:

"checking for i686-pc-linux-gnu-gcc option to produce PIC... -fPIC
checking if i686-pc-linux-gnu-gcc PIC flag -fPIC works... yes
checking if i686-pc-linux-gnu-gcc static flag -static works... yes
checking if i686-pc-linux-gnu-gcc supports -c -o file.o... yes
checking if i686-pc-linux-gnu-gcc supports -c -o file.lo... yes
checking if i686-pc-linux-gnu-gcc supports -fno-rtti -fno-exceptions... yes
checking whether the linker (/usr/bin/ld) supports shared libraries... yes
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking whether -lc should be explicitly linked in... no
creating libtool
checking for pkg-config... /usr/bin/pkg-config
checking for    esound >= 0.2.27        bonobo-activation-2.0 >= 2.1.0  
eel-2.0
>= 2.2.3        glib-2.0 >= 2   gnome-desktop-2.0 >= 2.1.0      
>gnome-vfs-2.0 >=
2.1.5  ORBit-2.0 >= 2.4.0      pango >= 1.1.2  gtk+-2.0 >= 2.1.1
libart-2.0 >= 2.3.10    libbonobo-2.0 >= 2.1.0  libbonoboui-2.0 >= 2.0.0
libgnome-2.0 >= 2.1.1   libgnomeui-2.0 >= 2.1.1librsvg-2.0 >= 2.0.1
libxml-2.0 >= 2.4.7... Package eel-2.0 was not found in the pkg-config 
search
path.
Perhaps you should add the directory containing `eel-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'eel-2.0' found

configure: error: Library requirements (        esound >= 0.2.27
bonobo-activation-2.0 >= 2.1.0  eel-2.0 >= 2.2.3        glib-2.0 >= 2
gnome-desktop-2.0 >= 2.1.0      gnome-vfs-2.0 >= 2.1.5  ORBit-2.0 >= 2.4.0
pango >= 1.1.2 gtk+-2.0 >= 2.1.1        libart-2.0 >= 2.3.10    
libbonobo-2.0 >=
2.1.0  libbonoboui-2.0 >= 2.0.0        libgnome-2.0 >= 2.1.1   
libgnomeui-2.0 >=
2.1.1         librsvg-2.0 >= 2.0.1    libxml-2.0 >= 2.4.7) not met; consider
adjusting the PKG_CONFIG_PATH environment variable if your libraries are in 
a
nonstandard prefix so pkg-config can find them. "

The GNOME_PREFIX has been set to '/usr' and PKG_CONFIG_PATH HAS been 
correctly set as explained in the book. As indicated by the output shown 
above, 'nautilus' is looking for 'eel.2.0.pc'
This, however, does not figure in the BLFS-5 Book. Nor had I heard fo 'eel' 
package before. Googleeing for it has yeilded the result 'eel-0.1.?' from 
'freshmeat'. Having extracted this 'eel' package, I find that there is no 
'configure' file in its directory. Also, I searched for 'eel' in the foster 
OS (SuSe-8.1) and it is not there in that distribution as well.

Can someone please help with this? Where can I find 'eel-2.0' or the later 
version and how to install?

Thanks in anticipation!

RSP

_________________________________________________________________
Marriage?  Join BharatMatrimony.com. 
http://www.bharatmatrimony.com/cgi-bin/bmclicks1.cgi?74




More information about the lfs-support mailing list