binutils check failure : ld-bootstrap

Alex Groenewoud alex at linuxfromscratch.org
Sat Feb 14 04:56:11 PST 2004


Ben Bryant wrote:
> Using LFS version 5.1-pre1, I'm now up to Chapter6:
> Installing bin-utils-2.14. Configure and make work
> fine, but when I run the make check, I get one failure
> in the ld tests:
> 
> Running
> /sources/binutils-2.14/ld/testsuit/ld-bootstrap/bootstrap.exp
> ...
> FAIL: bootstrap with --static.
> 
> All the other are fine.  

Could it be you ran a 'strip --strip-unneeded' on /tools/lib/*
instead of a --strip-debug?  The first seems to be okay for the
dynamic libraries, but appears to damage the static ones.

Try the 'make tooldir=/usr install' and then run the 'make check'
again.  If still not okay, then rm dirs, re-untar and rebuild the
package.  If it still fails that test, I think it is safe to
continue anyway, as nothing from /tools should get linked into the
$LFS stuff.  At least try to continue, running the test suites on
everything.  It should be interesting to see what else fails.  :)

Alex




More information about the lfs-support mailing list