LFS 5.0: autoconf/automake problems ?

Ken Moffat ken at kenmoffat.uklinux.net
Thu Feb 12 12:21:52 PST 2004


On Thu, 12 Feb 2004, lanas wrote:

> Le Mercredi 11 Février 2004 19:05, Ken Moffat a écrit :
>
> >  You sound as if you're playing mix and match with package versions,
> > which is generally a bad idea, but I'm not quite sure if I understand you
> > correctly.
>
> When I saw that there was a autoconf problem, I simply tried with a previous
> version from LFS 4.0.  This is hardly playing I think, but it's nonetheless
> not the right way anyhow.
>

I misinterpreted your original post.  Trying a previous / later version
is sometimes a possible fix, but it shouldn't be necessary for a
released version of the book.  Particularly when your host is an older
version of LFS (although keep in mind that the old build methods allowed
more errors to slip through).

>
> mnt/lfs/gawk-3.1.3/missing: aclocal-1.7: command not found
> WARNING: `aclocal-1.7' is missing on your system.  You should only need it if
>          you modified `acinclude.m4' or `configure.ac'.  You might want
>          to install the `Automake' and `Perl' packages.  Grab them from
>          any GNU archive site.
> cd . && \
>   /bin/sh /mnt/lfs/gawk-3.1.3/missing --run automake-1.7 --gnu  Makefile
> /mnt/lfs/gawk-3.1.3/missing: automake-1.7: command not found
>
> (There's a bit more that I can post if needed)
>
> However, gawk just went on building happily.


 Anything labelled WARNING is not expected to be a problem in LFS.
although if you've built a lot of BLFS you'll know that looking for the
warnings about missing packages can save you a  lot of time in the long
run.

>  When the turn for
> findutils-4.1.20 came, the problem was serious and brought the building of
> the system to a halt as of now:
>
> make[2]: Entering directory `/mnt/lfs/findutils-4.1.20/gnulib'
> cd . && /bin/sh /mnt/lfs/findutils-4.1.20/missing --run aclocal-1.7 -I m4
> /mnt/lfs/findutils-4.1.20/missing: aclocal-1.7: command not found
> WARNING: `aclocal-1.7' is needed, and you do not seem to have it handy on your
>          system.  You might have modified some files without having the
>          proper tools for further handling them.  Check the `README' file,
>          it often tells you about the needed prerequirements for installing
>          this package.  You may also peek at any GNU archive site, in case
>          some other package would contain this missing `aclocal-1.7' program.
> make[2]: *** [aclocal.m4] Error 1
> make[2]: Leaving directory `/mnt/lfs/findutils-4.1.20/gnulib'
>

 Ok, in this case the warning is followed immediately by an Error, so I
can understand why you would worry about the warning in gawk.

 Take a look at config.log in findutils.  I'm not clear if this sort of
error is immediate (i.e. it finds something is missing. tries to use
aclocal, and fails) or deferred (notes something is missing, then later
tries to run aclocal).  I've got a findutils directory here, but I'm not
in the middle of a build so mine has found the programs in different
places.  Look at the line numbers from configure that are reported to
get an idea how far it got, then look at that part of the configure
script.  I imagine it tried to find something, failed, then decided it
would have to use aclocal.  Any clues ?

Ken
-- 
Brighton tops UK Jedi league
http://www.theregister.co.uk/content/28/35186.html




More information about the lfs-support mailing list