Network Interface: link down

Ken Moffat ken at kenmoffat.uklinux.net
Tue Feb 10 13:38:18 PST 2004


On Tue, 10 Feb 2004, Dirk Kleinschmidt wrote:

> Hi Ken,
>
> Thanks for your help. Your sentence "Looks like it keeps losing the
> connection" brought me the solution.
> My notebook running WinXP was still searching for a dhcp server but on my
> lfs-box there isn't one running yet.
> I think this resulted in "link down" because it did not appear since I
> switched to a fix ip.
>
> But one questions is left: When I tried to compile the kernel with rtl8139
> as a module the network-cards didn't even boot because the modules haven't
> been loaded until the S20network script was executed. How do I load those
> drivers in an earlier state?
>
> Dirk
>

 I don't understand what you mean by "the network-cards didn't even
boot".  If you have "alias eth0 rtl8139too" in modules.conf (don't know
if you need it for eth1 as well, I've never tried using two identical
cards in one box) and the correct values for static IP addresses in
/etc/sysconfig/network* then it should just work with the current
bootscripts.  The problems have always been with dhcp (hopefully, the
new test version of the bootscripts fixes that).

Ken
-- 
Brighton tops UK Jedi league
http://www.theregister.co.uk/content/28/35186.html




More information about the lfs-support mailing list