problem booting with grub "File not found"

Thomas mubis at gmx.de
Wed Feb 4 06:39:22 PST 2004


Hallo,
> Can you give us the commands typed when you configured grub ?

I used the grub-configuration installed with RedHat 9.0.  I just added the LFS 
entries.

> Also, can you state the line just before "File not found" ?

Booting 'Linux from Scratch (LFS 5.0)'
root (hd0,5)
Filesystem type ist extfs, partition type 0x83
kernel /lfskernel.v.1.0 ro root=/dev/hda6
Error 15: File not found.


Hope this helps,

Thomas

> >
> > I've a problem booting my LFS-System.
> > Booting with grub, I get the message "File not found".
> > I do've a /boot - partition where the kernels (e.g.
> > lfskernel.v.1.0) are
> > located.
> > What could be the problem ?
> >
> > My LFS partition is hda6, RedHat and Suse ist booting fine.
> >
> > Thanks,
> > Thomas
> >
> > my grub.conf
> >
> >
> > default=0
> > timeout=10
> > #splashimage=(hd0,1)/grub/splash.xpm.gz
> > title Red Hat Linux 9.0 Apache 2
> >         root (hd0,1)
> >         kernel /vmlinuz-2.4.20-8smp ro root=LABEL=/
> >         initrd /initrd-2.4.20-8smp.img
> >
> > title SuSE 9.0 OpenLDAP Server 1.2
> >     kernel (hd0,4)/boot/vmlinuz-2.4.21-99-smp4G
> > root=/dev/hda5 splash=silent
> > desktop showopts
> >     initrd (hd0,4)/boot/initrd-2.4.21-99-smp4G
> >
> > title Linux from Scratch (LFS) 5.0
> >         root (hd0,5)
> >         kernel /lfskernel.v.1.0 ro root=/dev/hda6
>
> Can you give us the commands typed when you configured grub ?
> Also, can you state the line just before "File not found" ?




More information about the lfs-support mailing list