Can't mount vfat partition

Dienadel no at
Thu Dec 30 09:15:36 PST 2004

Matthias B. wrote:

> Have you run scandisk? Maybe there is something strange with the
> partition.

No problem detected in both (dev/hda2 and /dev/hda3) by scandisk 

> What about /dev/hda4? That seems to be a Windows partition, too. Do you
> get the same error when mounting it?

The problem is exaclty the same

> Have you tried booting with live-CD (e.g. Knoppix) and mounting the
> partition from that?

Yes, and they can be accesed ok. Even, from my LFS-5.1.1 there isn't any

> Try a different version of util-linux. Same problem?

My system was build with "Util-linux-2.12b". Now, i've installed 2.12i, and
the problem is the same.

> Build strace and run
> strace -q -o /tmp/mount.trace -f -F mount -t vfat /dev/hda2 /mnt
> and then post the file /tmp/mount.trace here.

The file is attached

> I've attached my kernel config for kernel 2.6.9. Try building a kernel
> with that (with the most minimal changes to make it work on your machine)
> and see if the problem persists.
> Try downgrading a few kernel versions. Does it make a difference?

Let me to test it, in a few days

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: mount.trace
URL: <>

More information about the lfs-support mailing list