kernel panic: no init found.

joe ody at
Thu Dec 30 06:19:32 PST 2004

host: Fedora2 -> /boot on /dev/hda6
      lfs 6   -> /     on /dev/hda12
      win32   ->       on /dev/hda1

I install fedora's grub on /dev/hda6.
I install LFS' grub on /dev/hda12

I've made LFS 6 through chapter 9 .
then rebooted, then the message was:
"Warning : unable to open initial console"
"Kernel panic : No init found. Try passing init= option to kernel"

Then I passed "init=/bin/sh", but still stuck.
When I install Fedora, I use params hda=My C/H/S etc,
I'm afraid it affects LFS installation.

Any other way booting into my lfs using floppy ? (can't find mkbootdisk)

I've tried dd if=/dev/hda12 of=~/boot.img bs=512 count=1 from
chrooted lfs, then I reboot using this file. (and failed)

I've tried adding root(hd0,11), kernel /boot/lfskernel-,
init=/bin/sh to my fedora's grub. (and failed)

Finally, I tried grub again from chrooted LFS, but
when I input "root (hd0,11)", the message was
"undefined device ..." (and failed)

Help me please... can't hold on...
thx in advance.

More information about the lfs-support mailing list