Can't mount vfat partition

Matthias B. msbREMOVE-THIS at
Thu Dec 30 03:51:45 PST 2004

Have you run scandisk? Maybe there is something strange with the

What about /dev/hda4? That seems to be a Windows partition, too. Do you
get the same error when mounting it?

Have you tried booting with live-CD (e.g. Knoppix) and mounting the
partition from that?

I've attached my kernel config for kernel 2.6.9. Try building a kernel
with that (with the most minimal changes to make it work on your machine)
and see if the problem persists.

Try downgrading a few kernel versions. Does it make a difference?

Try a different version of util-linux. Same problem?

Build strace and run

strace -q -o /tmp/mount.trace -f -F mount -t vfat /dev/hda2 /mnt

and then post the file /tmp/mount.trace here.


If Barbie is so popular, why do you have to buy her friends?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: config.bz2
Type: application/octet-stream
Size: 5438 bytes
Desc: not available
URL: <>

More information about the lfs-support mailing list