glibc-2.3.4-20040701: error with libc_pic.a

Andrei A. Voropaev av at
Thu Dec 30 02:51:14 PST 2004

On Thu, Dec 30, 2004 at 08:54:59AM +0000, Matthew Burgess wrote:
> Vladimir Rusinov aka B. wrote:
> >errno: TLS definition in /tools/glibc-build/libc_pic.a(errno.os) section
> >.tbss mismatches non-TLS reference in
> >/tools/glibc-build/elf/dl-allobjs.os/tools/glibc-build/libc_pic.a: could
> >not read symbols: Bad value collect2: ld returned 1 exit status
> A few of us have seen, and have been trying to diagnose this problem 
> recently.  It looks like Suse must have a stripped libc.a file, as this 
> is what tickles a bug in binutils.  Could you try compiling 
> binutils- instead of binutils- in chapter 5 
> please?  That shouldn't be affected by the TLS bug.  It may be useful if 
> you could tell us what the hosts' binutils version is too.

I've already tried with that version. No go. I've tried to fool it by
compiling glibc in chapter 5 with binutils-2.15 and then using newer
binutils in chapter 6 - the same problem came up. So I stepped back to
using binutils-2.15. And I was able to compile everything. BTW. What is
the background for using development versions of binutils?

Minds, like parachutes, function best when open

More information about the lfs-support mailing list