udev boot problem

Andrei A. Voropaev av at simcon-mt.com
Tue Dec 28 04:39:16 PST 2004

On Tue, Dec 28, 2004 at 08:57:58AM +0100, Schafer Frank wrote:
> Hi all,
> I've built a LFS 6.0 system. If I chroot into it, mount everything due
> to chapter 6 and start udev, then all devices come up gracefully.
> If I boot the new system using grub from the build system only the root
> partition get checked. fsck for the /boot partition and the /usr/local
> fails with ''/dev/hdc[14] device not found''. So does swap (/dev/hdc2).
> The boot continues and dies with ''tty[1-6] respawning too fast'' and in
> the end ''no processes left in this runlevel''
> Seems udev doesn't create devices if I boot into this system. Build and
> target system are using the same kernel.
> Has anyone met this?
> If this will be solved ... I'm not too wise from the grub info pages.
> Can I install grub in this way:
> 	grub> root(hd2,0)
> 	grub> setup(hd2)
> and then in the menu.lst for this installation:
> 	title LFS
> 	root (hd0,0)
> 	kernel /bzImage.20041227 root=/dev/hda3
> where /boot is on the first and / on the third partition of the third
> disk of the build system which I move to the first HD of the target
> system?
> ... with a modified fstab, of course ;)

Yep. I've hit almost the same problem and exactly today. Is it special
day? :) In my case init scripts just report that device for swap partion
was not found and then system was halted. I'm trying to figure it out now.


PS. As a side note. I've tried to install module-init-tools-3.1 and it
appears that now they use docbook2html to create one of the man pages,
and make fails because they don't even check if docbook exists. With
this new requirement, lots of libraries will have to be added to base
system :)

More information about the lfs-support mailing list