Get a newer version of e2fsck?

Steve Crosby fost at
Sat Dec 25 23:00:24 PST 2004

Michael Kipper <mkipper at> wrote in news:cqljmf$uom$1

> Hi,
> Got my LFS 6.0 built with Fedora Core 3, then I rebooted and tried to get
> into my system.
> I got the error that went something like:
> e2fsck.ext3: Unsupported features on (lfs/)
> Get a newer version of e2fsck.
> I checked that FC3 has e2fsck 1.35, and that's what I built into LFS.
> I rebuilt it, just to be sure, and got the same error.
> What have I done?
> Thanks,
> Michael

from your HOST system, do a tune2fs -l /dev/<whateveryourLFSrootparitionis> 
| grep features

This will list the filesystem features that your new ext3 partition has 
been created with. It's likely that FC3 has some extensions of e2fsprogs 
that are not in the base distribution, and therefore not supported from 
within LFS.

you can use tune2fs to remove features not found in LFS - use the man pages  
for mke2fs on LFS and on your host to see the differences in available 

- --
Steve Crosby

More information about the lfs-support mailing list