CDROM Boot Initrd Problem

Markus Mahlberg markus.mahlberg at
Thu Dec 16 08:47:12 PST 2004

Charles Meier wrote:

> System is an LFS 5.1 w/ Linux  I've created a boot CD
> using lilo and BusyBox.  This boots easily on the machine where
> the LFS was built.  This box is a dual PIII.  The CD also boots
> on a Dell PIII laptop.  But the CD refuses to boot on my older
> boxs -- one w/ a K6/300 (mail server) and the other with a PII/200
> (replacement firewall/router).  On those machines, the kernel boots
> as far as the "Freeing unused kernel memory" message and then appears
> to hang w/ no further msgs.  This is the point where /linuxrc should
> kick in, but no dice.
> I've tried the obvious.  The kernel was compiled w/ the basic
> Pentium option.  Busybox was compiled w/ -march=i386.  It doesn't
> appear to be a problem with the arch options used to compile
> the system.
> I started using Linux using a pre-version 1 SLS install.  I've
> been upgrading machines from scratch since before there was an
> LFS (Kudos to the LFS team -- you're directions have made upgrades
> much, much faster) and have always managed to do it successfully
> with only occasional references to usenet archives.  But this one
> has me completely baffled.
> Any ideas?
> cmeier

What about trying the "generic x86-support" option when compiling the
I did a boot-CD myself, and it's perfectly working on all Systems I've
tried so far, but only since I activated this option.
Sneaking around the net...

More information about the lfs-support mailing list