Kernel panic: VFS: unable to mount root fs

Clark, David A., SGT - 75th Rangers clarkda at
Mon Dec 13 13:50:54 PST 2004


Hi. My name is David. My friends at work call me Sparky, and it worked as a
user name. A while back, I first made the switch from Windows to Linux, and
found Gentoo to be a good starting point for me. I was never happier. :)

Lo and behold, my wife--who is, incidentally, not very savvy with these sort
of things--hated it. Naturally, I installed Windows again to sleep better at
night, but I left half of my disc blank for the day I'd install Linux again.

Fast forward a few months, and I found LFS, which a couple people talked
about on the board as "the way to go if you really want to learn Linux". I
downloaded the most recent book, packages, and patches; burnt one of the
Live CDs; and off I went. I followed along with the book without a
hitch--learning a LOT along the way--all the way until after the part where
you reboot, register, and enjoy.


Kernel panic: VFS: unable to mount root fs

I'm not a total idiot, and I THOUGHT I knew how to fix the problem, until
everything I knew to check checked out.

So, I checked the FAQ, and here's where I'm at...

Q: Did you specify the correct partition in /etc/lilo.conf?
A: Menu.lst applies to me because I'm using Grub. Windows is installed on
/dev/hda0, Linux on /dev/hda4 (ext3), with /boot on /dev/hda2 (ext2) and my
swapfile on /dev/hda2. My guess is that menu.lst should look like this:

root (hd0,1)
kernel /lfskernel- root=/dev/hda2

That didn't work, so I tried this:

root (hd0,3)
Kernel /lfskernel- root=/dev/hda4

This is even worse because Grub gives me "File not found" and won't even
begin to boot. Sadly, after that, I tried in vein every combination that
shouldn't work in hopes that something would work.

Q: Did you remember to rerun lilo after changing /etc/lilo.conf?
A: I'm using Grub, but I did rerun it anyway, and even tried installing it
on (hd0,1) instead of the MBR. No dice here, either.

Q: Is support for the hard drive enabled in the kernel?
A: Yep.

Q: Is support for the hard drive compiled into the kernel, not just as a
A: Yep, I configured my kernel for NO modules.

Q: Is support for the filesystem compiled into the kernel?
A: Yes, same as above.

I've looked through the FAQ of course, and I didn't find anything in the
hints. Maybe I missed it though. I'd definitely appreciate any help... I'd
hate to have to fdisk the whole thing and start over.


Rangers Lead the Way!!!

More information about the lfs-support mailing list