lfs 5.1.1 : groff-1.19 with config.log

Matthias B. msbREMOVE-THIS at winterdrache.de
Wed Dec 8 02:41:57 PST 2004


On Wed,  8 Dec 2004 09:01:22 +0100 gregory.roche at free.fr wrote:


> In the chapter 6 of Manual LFS 5.1.1, when I want configure groff, I

You are in chapter 6 at the groff installation. This means that you should
already have done the chapter 6 installation of GCC.

However, look at this fragment from config.log

> Reading specs from /tools/lib/gcc-lib/i686-pc-linux-gnu/3.3.3/specs
> Configured with: ../gcc-3.3.3/configure --prefix=/tools
> --with-local-prefix=/tools --enable-clocale=gnu --enable-shared --enable
> -threads=posix --enable-__cxa_atexit --enable-languages=c,c++

You're obviously still running the chapter 5 GCC. Apparently you forgot to
install GCC in chapter 6. This is bad. You will have to redo chapter 6
from the point of the GCC installation. 
IMPORTANT: DO NOT continue at the groff installation after the chapter 6
GCC installation. You have to do everything in chapter 6 again beginning
with the GCC installation, i.e. GCC-3.3.3,
Coreutils-5.2.1,Zlib-1.2.1,Mktemp-1.5,Iana-Etc-1.00,Findutils-4.1.20,
Gawk-3.1.3,Ncurses-5.4,Vim-6.2,M4-1.4,Bison-1.875,Less-382 

Be more careful next time. Skipping packages is VERY BAD. You may want to
check again that you've not skipped other packages. If you're not sure
it's better to restart chapter 6 from the beginning.

MSB

-- 
You cannot teach a square to be round.




More information about the lfs-support mailing list