grub doesn't want to install

A- Team Hannibal-Smith at gmx.at
Tue Aug 3 03:49:17 PDT 2004


Ok, I finally reached chapter 8. Until now I managed everything (even though
I never used linux before...) but now I'm stuck. first my hd-configuration:

hda cdrom
hdb cdrom
hdc1 Debian (ext3)
hdc2 Debian swap
hdc3 LFS (ext3)
hdc4 LFS swap

I know this is strange, but the reason is, that I used to boot windoze from
a Promise raid and my cdroms were attached like this. When I then decided to
go through lfs I realized to late that it could cause problems (even though
I didn't have any until now) and since I don't know how to change the config
in debian I will just leave it this way...

Now to my problem:
when I try to install grub like stated in the lfs-book I get the following
errors:
----------------this is still fine:-------------------------------
grub> root (hd0,2)
 Filesystem type is ext2fs, partition type 0x83

----------------and here it comes:--------------------------------
grub> setup (hd0)
 Checking if "/boot/grub/stage1" exists... yes
 Checking if "/boot/grub/stage2" exists... yes
 Checking if "/boot/grub/e2fs_stage1_5" exists... yes
 Running "embed /boot/grub/e2fs_stage1_5 (hd0)"...  15 sectors are embedded.
succeeded
 Running "install /boot/grub/stage1 (hd0) (hd0)1+15 p
(hd0,2)/boot/grub/stage2
/boot/grub/menu.lst"... failed

Error 12: Invalid device requested

------------------------------------------------------------------
Does anyone have any idea? I couldn't find anything in the grub info or the
net...

thanks in adavnce

Denis

-- 
NEU: WLAN-Router für 0,- EUR* - auch für DSL-Wechsler!
GMX DSL = supergünstig & kabellos http://www.gmx.net/de/go/dsl




More information about the lfs-support mailing list