glibc and gcc issues

linux at nplinux.org linux at nplinux.org
Thu Apr 29 23:36:17 PDT 2004


Dear all,

In the LFS book 5.0 i have seen gcc-3.3.1 with glibc - 2.3.2 and a patch
glibc-2.3.2-sscanf-1.patch. this works great....


now is there any patch for working with gcc .3.4.0 with glibc 2.3.2? 
without this patch i guess... i got this error message...

---------
pc-linux-gnu/3.4.0/include -isystem /tools/include -D_LIBC_REENTRANT
-include ../include/libc-symbols.h       -D_IO_MTSAFE_IO -o
/nplinux/sources/glibc-build/stdio-common/sscanf.o
sscanf.c:31: error: conflicting types for 'sscanf'
sscanf.c:31: error: conflicting types for 'sscanf'
sscanf.c:48: error: conflicting types for '_IO_sscanf'
../libio/iolibio.h:42: error: previous declaration of '_IO_sscanf' was here
sscanf.c:48: error: conflicting types for '_IO_sscanf'
../libio/iolibio.h:42: error: previous declaration of '_IO_sscanf' was here
sscanf.c: In function `sscanf':
sscanf.c:37: error: `va_start' used in function with fixed args
make[2]: *** [/nplinux/sources/glibc-build/stdio-common/sscanf.o] Error 1
make[2]: Leaving directory `/nplinux/sources/glibc-2.3.2/stdio-common'
make[1]: *** [stdio-common/subdir_lib] Error 2
make[1]: Leaving directory `/nplinux/sources/glibc-2.3.2'
make: *** [all] Error 2
-------------------

Am i forced to use gcc 3.3.1 and glibc 2.3.2?


Thanks
Paras








More information about the lfs-support mailing list