(no subject)

Ken Moffat ken at kenmoffat.uklinux.net
Wed Apr 28 05:57:31 PDT 2004


On Wed, 28 Apr 2004, Basanta shrestha wrote:

> binutils 2.14
> gcc 3.3.1
> linux 2.4.22
> glibc 2.3.2
> tcl 8.4.6
> expect 5.40
> dejagnu 1.4.4
> binutils pass 2                error  while running " make check" as follows:
>

 You seem to be building LFS-5.0 with upgrades to some of the versions.
That isn't always a good idea, but I don't think upgrading tcl, expect,
dejagnu is a problem.  When you get to building the kernel at the end of
the book, please upgrade it to at least 2.4.25 to fix vulnerabilities.

>
> __________________________________________
> WARNING: Couldn't find the global config file.
> WARNING: Couldn't find tool init file
> WARNING: Couldn't find the global config file.
> WARNING: Couldn't find tool init file
> WARNING: Couldn't find the global config file.
> WARNING: Couldn't find tool init file
> ERROR: /nplinux/sources/binutils-2.14/ld/testsuite/ld-selective/3.cc: compilation failed
> ERROR: /nplinux/sources/binutils-2.14/ld/testsuite/ld-selective/4.cc: compilation failed
> ERROR: /nplinux/sources/binutils-2.14/ld/testsuite/ld-selective/5.cc: compilation failed

 Compilation failing isn't a usual error.  These look like c++ programs.
My initial guess is that you failed to get a working c++ compiler in the
second build of gcc.  Did you remember the --enable-languages=c,c++
option when you built pass 2 gcc ?  If you're happy that your c++
compiler was built, try compiling `3.cc' manually, to see what errors
come out.

Ken
-- 
 das eine Mal als Tragödie, das andere Mal als Farce




More information about the lfs-support mailing list