SOLVED: binutils make LDFLAGS error permission denied

John Hanagan jhan56 at excite.com
Tue Apr 27 14:53:46 PDT 2004


Thanks for the hint, but that wasn't it.  What it was, Mandrake didn't install
 flex by default.  I tried installinf flex when I took a leap that perhaps arlex and other lex references didn't fail because of permissions but because they 
were missing.  




 --- On Mon 04/26, =?ISO-8859-1?Q?Jens_H=FClser?= < alphabingo at epost.de > wrote:
From: =?ISO-8859-1?Q?Jens_H=FClser?= [mailto: alphabingo at epost.de]
To: jhan56 at excite.com
Date: Mon, 26 Apr 2004 19:03:50 +0200
Subject: Re: binutils make LDFLAGS error permission denied

<br><br>Am 26 Apr 2004 um 11:44 hat John Hanagan geschrieben:<br><br>> <br>> Hi, this is my first attempt at LFS and I hit a wall right away,<br>> compiling binutils-2.14, command: make LDFLAGS="-all-static"<br>> screen of error is below.  Any hints?  Book version 5.0 Host Mandrake 9.1<br>> binutils-2.14<br>> no book deviations (and I looked for omissions)<br>> last part of error was arlex.l:Permission denied<br>> all the directories and contents are owned by lfs and I even tried<br>> with the whole world having write permission to everything in $LFS.<br>> <br>> text:<br>> gcc -DHAVE_CONFIG_H -I. -I../../binutils-2.14/binutils -I. -D_GNU_SOURCE -I. -I../../binutils-2.14/binutils -I../bfd<br>> -I../../binutils-2.14/binutils/../bfd -I../../binutils-2.14/binutils/../include -I../../binutils-2.14/binutils/../intl<br>> -I../intl -DLOCALEDIR="\"/tools/share/locale\"" -Dbin_dummy_emulation=bin_vanilla_emulation   -W -Wall<br>> -Wstrict-prototypes -Wmissing-prototypes -g -O2 -c ../../binutils-2.14/binutils/arparse.c /bin/sh<br>> ../../binutils-2.14/binutils/../ylwrap "" ../../binutils-2.14/binutils/arlex.l lex.yy.c arlex.c --<br>> ../../binutils-2.14/binutils/../ylwrap: line 86:<br>> /mnt/lfs/sources/binutils-build/binutils/../../binutils-2.14/binutils/arlex.l: Permission denied make[3]: *** [arlex.c]<br>> Error 1 make[3]: Leaving directory `/mnt/lfs/sources/binutils-build/binutils' make[2]: *** [all-recursive] Error 1<br>> make[2]: Leaving directory `/mnt/lfs/sources/binutils-build/binutils' make[1]: *** [all-recursive-am] Error 2 make[1]:<br>> Leaving directory `/mnt/lfs/sources/binutils-build/binutils' make: *** [all-binutils] Error 2<br>> <br>> the above is the last section of my output when trying<br>> make LDFLAGS="-all-static"<br>                                  ^<br>must be "-all -static"<br><br>and one more time (as I didn't see it myself the first time I tried): "-<br>all           -static" ;-D<br>> <br>> <br>> <br>> <br>> <br>> _______________________________________________<br>> Join Excite! - http://www.excite.com<br>> The most personalized portal on the Web!<br>> -- <br>> http://linuxfromscratch.org/mailman/listinfo/lfs-support<br>> FAQ: http://www.linuxfromscratch.org/lfs/faq.html<br>> Unsubscribe: See the above information page<br><br><br>

_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!



More information about the lfs-support mailing list