problems booting LFS on VIA MVP3-based boards

Ken Moffat ken at kenmoffat.uklinux.net
Thu Apr 22 04:10:39 PDT 2004


On Thu, 22 Apr 2004 blux.net at lineone.net wrote:

> Greetings,
>
> I  am probably now proficient at building LFS5.2.  My last build was on
> a pentium machine (CPU K6/3-400 M/B chipset VIA MVP3).  I have built on
> this board with SuSE9 amnd Mandrake 9.2.  The second build was perfect.
>  I however was unable to boot.  I tried another MVP3-based machine this
> time with a K6/2-350 it gave the same result.  I then  tried the build on
> a machine with CPU=Celeron1100, chipset VIA694.  It booted perfectly.  I
> then took the build from the celeron machine and tried it on the  MVP3-based
> machines and they also failed to boot.   Now standard Linux distributions
> (Fedora1, SuSE9, Redhat9, Mandrake8.x,9.x)etc all run (and thus boot) on
> the MVP3-based machines.  I even sucessfulluy used the 'boot from installed
> system" utility on a SuSE9 install CDROM to boot the LFS-system on the troublesome
> mvp3-based machine.
>

 First part sounds very much as if your *kernel* is built for too "high"
a processor (e.g. i686 when you've only got i586).  I've seen people
suggest that K6s will run i686 code, but I've never tried it myself
(CONFIG_M586 or CONFIG_MK6, depending on age of kernel and version of
gcc), and others who post that it definitely doesn't support the cmov
instruction.  It might even differ between the k6, k6/2, k6/3 for all I
know.

 Vendor kernels for mdk and I believe Suse are i586, RH used to ship
with i386 and i686, don't know about fedora.

 The only thing against this is the "boot from installed system"
utility.  When you use that, does it use your LFS kernel, or does it use
its own kernel ?

Ken
-- 
 das eine Mal als Tragödie, das andere Mal als Farce




More information about the lfs-support mailing list