[elf/subdir_lib] Error 2

Linux Tard linuxtard at yahoo.com
Wed Apr 21 14:18:27 PDT 2004


Hello.  I'm new to LFS.

I've followed the online book process and reached the
point of INSTALLING GLIBC-2.3.2 here;

http://lfs.oregonstate.edu/lfs/view/stable/chapter06/glibc.html

Everything worked fine up to this point;

'make'

At this point the process exited with this error;

/glibc3/elf/librtld.os(.text+0xfc99):../sysdeps/unix/closedir.c:35:
undefined reference to `errno'
/glibc3/elf/librtld.os(.text+0xfccf): In function
`__readdir':
../sysdeps/unix/readdir.c:43: undefined reference to
`errno'
/glibc3/elf/librtld.os(.text+0xfd5e):../sysdeps/unix/readdir.c:76:
undefined reference to `errno'
/glibc3/elf/librtld.os(.text+0xfd6a):../sysdeps/unix/readdir.c:78:
undefined reference to `errno'
/glibc3/elf/librtld.os(.text+0xfdbf): In function
`__getdents':
../sysdeps/unix/sysv/linux/getdents.c:109: undefined
reference to `errno'
/glibc3/elf/librtld.os(.text+0xff14):../sysdeps/unix/sysv/linux/getdents.c:189:
more undefined references to `errno' follow
collect2: ld returned 1 exit status
make[2]: *** [/glibc3/elf/ld.so] Error 1
make[2]: Leaving directory `/glibc3/glibc-2.3.2/elf'
make[1]: *** [elf/subdir_lib] Error 2
make[1]: Leaving directory `/glibc3/glibc-2.3.2'
make: *** [all] Error 2


I'm totally at a loss as to why this happened.  But
for 'fun' I typed in 'make install' and received
either the exact same or very similar error.  

I don't know if this matters or not, but my running
system is Fedora Core 1 and I was using everything
described in LFS 5 book except kernel 2.4.26. 
Everything up to this stage worked flawlessly.

Has anyone a pointer to what I've flubbed or where to
fix?

regards,

lt


	
		
__________________________________
Do you Yahoo!?
Yahoo! Photos: High-quality 4x6 digital prints for 25¢
http://photos.yahoo.com/ph/print_splash



More information about the lfs-support mailing list