Expect is missing

Tom Black tcblack at wireless111.net
Mon Apr 19 20:27:05 PDT 2004


Jeremy Utley wrote:
> Tom Black wrote:
> 
>> Ok, I've gotten through to chapter 6 in the Chroot environment, 
>> re-adjusted the toolchain, deleted the binutils directories and was 
>> starting to install binutils.  When I arrived at the test for pseudo 
>> terminals I typed
>> expect -c "spawn ls" and got the following error:
>> expect: command not found
>> it's not in
>> I've read through the faq's and searched but can not yet find a 
>> relevant answer.
>>
>> readelf -l /tools/bin/expect | grep terpr
>> results in readelf: Error: Cannot stat input file /tools/bin/expect.
>>  echoing the $PATH shows
>> /bin:/usr/bin:/sbin:/usr/sbin:/tools/bin
>>
>>
>> I tried to reinstall expect from here (probably not all that smart) 
>> but ran the following command from the book:
>> ./configure --prefix=/tools --with-tcl=/tools/lib --with-x=no
>>
>> amidst all the other stuff I get the message
>>
>> checking for Tcl private headers... checking for tclInt.h... no
>> configure: error: Can't find Tcl private headers
>>
>>
>> How far back do I have to go?  All the way?  Can I continue to work 
>> from within the Chroot and backup only a bit, or do I start over again?
>>
> You didn't leave the TCL source directory in place like you were told to 
> at the end of that package.  You'll need to drop back that far, 
> reinstall TCL, and MAKE SURE you do not delete that one after it's 
> done.  Wait till after expect to do that.
> 
> -J-
> 
argggh!  I really dislike missing something so blatantly obvious.
I reinstalled TCL and expect.
the test worked fine and I'm moving forward.
Now, I guess in addition to trying to learn Linux, I'm trying to learn 
to *follow directions* 8-)


-- 
Thomas Black
Total Linux Newbie (But trying to cure it)
http://wr189.wireless111.com



More information about the lfs-support mailing list