Problems with compiling autoconf 2.57 or 2.59

Markus Rothenbusch markus at itamarkroth.de
Sun Apr 18 23:43:34 PDT 2004


Jack wrote:

> On 2004.04.17 15:13, Allard Welter wrote:
>
>> On Saturday 17 April 2004 17:58, markus at itamarkroth.de wrote:
>> > Hello,
>> > I've got the following problem, if I try to compile autoconf, it
>> appears
>> > after starting 'make':
>> > make[3]: Leaving directory `/sources/autoconf-2.59/lib'
>> > ../../tests/autom4te                            \
>> >         --language=m4sugar                      \
>> >         --freeze                        \
>> >         --output=m4sugar.m4f
>> > Can't locate Data/Dumper.pm in @INC (@INC contains:
>> > /sources/autoconf-2.59/tests
>> > /../lib /tools/lib/perl5/5.8.0/i686-linux /tools/lib/perl5/5.8.0
>>            ^^^^^
>> > /tools/lib/perl
>>    ^^^^^
>> > 5/site_perl/5.8.0/i686-linux /tools/lib/perl5/site_perl/5.8.0
>> > /tools/lib/perl5/s
>> > ite_perl .) at /sources/autoconf-2.59/tests/../lib/Autom4te/C4che.
>> pm
>> > line 35.
>> > BEGIN failed--compilation aborted at
>> > /sources/autoconf-2.59/tests/../lib/Autom4t
>> > e/C4che.pm line 35.
>> > Compilation failed in require at
>> > /sources/autoconf-2.59/tests/.././bin/autom4te
>> > line 39.
>> > BEGIN failed--compilation aborted at
>> > /sources/autoconf-2.59/tests/.././bin/autom
>> > 4te line 39.
>> > make[2]: *** [m4sugar.m4f] Error 2
>> > make[2]: Leaving directory `/sources/autoconf-2.59/lib/m4sugar'
>> > make[1]: *** [all-recursive] Error 1
>> > make[1]: Leaving directory `/sources/autoconf-2.59/lib'
>> > make: *** [all-recursive] Error 1
>>
>> I don't know this error, but since no-one is responding I'll guess.
>> This
>> smells of a perl problem. Did perl install cleanly? did you run the
>> tests?
>>
>> The other thing that strikes me is that /tools is still being referred
>> to. So
>> either something is wrong with your path, or my guess above is
>> correct.
>>
>> >
>> > I guess I know, what the problem is, but I don't know how to solve
>> it.
>> >
>> > I tried to use autoconf 2.59 instead of autoconf 2.57 because I
>> thougt
>> > the archive could be demaged.
>> >
>> > Please help me...
>> >
>> > Greets
>> > Markus Rothenbusch
>>
>> Allard
>>
>> -- 
>> allard at quicknet.nl
>
>
> Someone just posted about the same problem last month, and it was a 
> bad symlink to perl.  The original solution was:
>
> I had a link the link /usr/bin/perl to /tools/usr/bin/perl that was 
> created in Chapter 5.  I removed the link and pointed it to 
> /usr/bin/perl5.8.0 and now it works, so far anyway.

Hello,

thank you for your help.

I compiled perl once again and it worked.

Markus Rothenbusch




More information about the lfs-support mailing list