help with toolchain reuse LFS5.2

blux.net at lineone.net blux.net at lineone.net
Sun Apr 18 08:00:24 PDT 2004


I have saved one toolchain after completing LFS and I have saved another
after completing chapter5.    Both gave the same result.

The LFS book states that tcl, dejagnu and expect should be re-installed
with prefix=/usr.  I am trying to do as instructed without success.  I 
also  am unable to install glibC-2.3.3.  

Thanks for your suggestion and if you have others please let me have them.

sincerely
Blux
>-- Original Message --
>Date: Sun, 18 Apr 2004 16:31:36 +0200
>From: Allard Welter <allard at nospam.nl>
>To: lfs-support at linuxfromscratch.org
>Subject: Re: help with toolchain reuse LFS5.2
>Reply-To: LFS Support List <lfs-support at linuxfromscratch.org>
>
>
>On Sunday 18 April 2004 16:03, blux.net at lineone.net wrote:
>>
>> I now want to re-use  a toolchain. After untarring a previously saved
>> 'tools' I arrived at the  chroot environment " I have no name " prompt
>> successfully. I created directories, symlinks etc but cannot install
>> expect, tcl and degagnu with prefix=/usr.    There seems to be a
>> configuraton problem. make_devices and man-pages-1.66 can be installed
>(the
>> latter  by "make install". I even symlinked gcc  and cc from /tools/bin
>to
>> /usr/bin all with the same result.
>>
>Right I get it now. Did you save the tool-chain after completing the entire
>
>LFS (wrong) or immediately after finishing ch5 (right)? The thing is that
>if 
>you save the toolchain after completing LFS the toolchain has been 
>re-adjusted to link to stuff that won't exist yet if you're trying to re-use
>
>it.
>
>Regards, Allard.
>
>-- 
>allard at quicknet.nl
>-- 
>http://linuxfromscratch.org/mailman/listinfo/lfs-support
>FAQ: http://www.linuxfromscratch.org/lfs/faq.html
>Unsubscribe: See the above information page





More information about the lfs-support mailing list