help with modules_install, booting -LFS5.2

Daniel Espinoza despinoz at isye.gatech.edu
Thu Apr 15 06:40:30 PDT 2004


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Thursday 15 April 2004 07:45, blux.net at lineone.net wrote:
> many thanks for your uggestion.
>
>  I have linked /bin/depmod to /sbin/depmod rebuilt the kernel and make
> modules_install now report no errors.  The system still does not boot.
>
> Below are my 'departures' from the prescribed LFS:
>
> 1) I compiled kernel 2.4.25 in /usr/src.  I made the taditional linux
> symlink to linux-2.4.25 (after decompressing the archive).
> 2) I used an ext3  partition.  However I adjusted /etc/fstab and I ran
> tune2fs -j  /dev/hda5 as instructed  from
> http://www.linuxfromscratch.org/blfs/view/stable/postlfs/ext3.html
>
> Any suggestion if any of the above could be causing the problem, are
> welcomed.

none of those changes should create a problem by themselves
>
> I also noticed that the LFS bootscripts seems not to be executable  I
> installed them as instructed
> http://www.linuxfromscratch.org/lfs/view/cvs/chapter07/bootscripts.html
>
All of them should be executable at least by root (and maybe only by root)

> but after kernel installtion, bootdisk making boot-loader installation
> typing commands such as reboot, halt or 'sh reboot', 'sh halt' are ignored
> (even from within the /etc/rc.d/init.d dircetory).  Could  anyone explain
> if these scripts are to be made executible?
>
> Also the grub bootfloppy just generate a series of zeros.

Did you use grub on disk?, did you update the menu.1st file? do you get any 
kernel panic or info while booting?, las time I get a lot of zeros t boot 
time was because LILO was badly installed and the MBR was corrupted

That's all I can imagine, good luck

Daniel
>
> All suggestions welcomed.
>
> blux
>
> >-- Original Message --
> >From: Daniel Espinoza <despinoz at isye.gatech.edu>
> >To: LFS Support List <lfs-support at linuxfromscratch.org>
> >Date: Wed, 14 Apr 2004 13:46:20 -0400
> >Subject: Re: helo with modules_install, booting -LFS5.2
> >Reply-To: despinoz at isye.gatech.edu,
> >	LFS Support List <lfs-support at linuxfromscratch.org>
> >
> >
> >-----BEGIN PGP SIGNED MESSAGE-----
> >Hash: SHA1
> >
> >the output message says that you are missing /sbin/depmod program, try
>
> to
>
> >find
> >it in your installation (you should have it, you may use
> >`find / -mount -name depmod` to lacate it) and make a symlink to /sbin
>
> of
>
> >it,
> >that should fix it
> >
> >Daniel
> >
> >On Wednesday 14 April 2004 13:10, blux.net at lineone.net wrote:
> >> Greetings,
> >>
> >>  I need some help with booting a new installation of LFS5.2.  The build
> >> machine  is a K63-cpu with SuSE9 (kernel 2.4.21).  I compiled 2 LFS
> >> kernel images:-
> >>
> >> (a) using  the config file of the host (config-2.4.21-99-default) and
> >> (b) using the 'default' config menu of LFS.
> >>
> >> Both made 'bZimages' and modules without errors.  Both however reported
> >> a error during module installation.  Specifically regarding pcmcia.
>
> The
>
> >> attached file ( 'make-modules-install-LFS-kernel-error')  show the
> >> reported errors.  I assumed that as directories for the modules existed 
> >> in /lib/modules, the machine would at least boot  if even to a kernel
> >> panic.
> >>
> >> I then configured bootloaders:-
> >>
> >> (a) I disregarded the LFS instruction and used (1) LILO  then (2) GRUB
> >
> >from
> >
> >> SuSE9.   On each oocassion, on selection of the kernel image to boot,
> >> the machine simply reboots.
> >>
> >> (b) I followed to the letter the LFS instruction and configured GRUB.
> >
> >The
> >
> >> 'grub-lst-file' file is attached.  The SuSE9 entry boots OK but as
> >> before the entries for the LFS kernel images simply reboot the machine.
> >>
> >> Curuiously if a SuSE-CDROM boot is attempted, on selection of
> >> 'boot-installed-system', an entry for the LFS partition is revealed.
>
>  If
>
> >> this is selected  a bash-2.05b prompt is immediately arrived at. 
> >> Commands such as 'ls'  and 'vi' are obeyed but not 'shutdown' nor
> >> 'reboot'.
> >>
> >> I have checked my installation procedure, but so far unaware of any
> >> major blunders.  Any advice on the kernel module installation errors
> >> reported above would be appreciated. Help  with the booting problems
> >> would also be appreciated.
> >>
> >> Yours sincerely
> >> Blux.
> >
> >- --
> >- ----------------------------------------------------------------
> >Daniel Espinoza Gonzalez
> >School of Industrial & Systems Eng.
> >Georgia Institute of Technology
> >e-mail : daespino at bellsouth.net
> >ICQ Number : 78184610
> >
> >- -----------------------------------------------------------------
> >-----BEGIN PGP SIGNATURE-----
> >Version: GnuPG v1.2.4 (GNU/Linux)
> >
> >iD8DBQFAfXjsgvFkTX9PWJwRAkdZAJ9eYv8G9D6FWr8bEyANAXnoaBWIwwCgtIT2
> >E9AiMLShsJeWyzg5Z9btCd4=
> >=1Hls
> >-----END PGP SIGNATURE-----
> >--
> >http://linuxfromscratch.org/mailman/listinfo/lfs-support
> >FAQ: http://www.linuxfromscratch.org/lfs/faq.html
> >Unsubscribe: See the above information page

- -- 
- ----------------------------------------------------------------
Daniel Espinoza Gonzalez
School of Industrial & Systems Eng.
Georgia Institute of Technology
e-mail : daespino at bellsouth.net
ICQ Number : 78184610

- -----------------------------------------------------------------
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFAfpDPgvFkTX9PWJwRAizGAJwJPg5BGWLfQhgz9Dgg6nNuId2O/wCgt64O
glMjgYz01o9zT5iKSvtb5l4=
=prgh
-----END PGP SIGNATURE-----



More information about the lfs-support mailing list