Doesn't ask for password - doesn't login successfully

shalomnaumann at rogers.com shalomnaumann at rogers.com
Sat Apr 10 20:33:07 PDT 2004


Thank you very much. I reinstalled shadow without optimization and it worked.

Shalom

> 
> From: Ken Moffat <ken at kenmoffat.uklinux.net>
> Date: 2004/04/09 Fri PM 05:29:59 EDT
> To: LFS Support List <lfs-support at linuxfromscratch.org>
> Subject: Re: Doesn't ask for password - doesn't login successfully
> 
> On Fri, 9 Apr 2004 shalomnaumann at rogers.com wrote:
> 
> > Hi,
> >
> > After spending lots of time, I finally got my LFS system
> > installed...but it doesn't work. It boots up fine (though that took a
> > rebuild of the kernel with a better configuration), and that goes much
> > faster than on any distribution I've used before, but my problems
> > start at the login.
> >
> > Basically, it gives the Login: prompt, but when I enter any username
> > (I've tried root, which I have set a password for, shalom, which I've
> > useradded but haven't set a password for, and goose, which doesn't
> > exist). For all of them it just pauses for a few seconds and then
> > returns to the Login: prompt. It doesn't ask for a password and it
> > doesn't log in.
> >
> > Everything works fine in the chroot'ed environment. I can su , su -,
> > su shalom, and su - shalom successfully.
> 
>  In chroot you bypass the login process.  I don't recall any past
> problems where the system didn't ask for a password, so I suggest that
> while you're in chroot you have a look at everything in /var/log,
> particularly auth.log, to see if there are any clues.
> 
> >
> > What did I do wrong and what must I do to fix it? I totally have no
> > idea where to start. What controls the login part of the linux system?
> > What could I have done wrong to make it fail. I more or less followed
> > the book to the letter (though I did make a few mistakes including
> > compilation of glibc with -O3 -march=pentium4 optimization and I
> > didn't realise that I was unsuccessful in my install of both ncurses
> > and binutils until I chrooted at the end of the book without /tools
> > being in my path and they didn't work. I fixed that, though).
> >
> 
>  Appendix B says that login is installed by shadow.  Like you I've no
> real idea about the detail of the login process, but shadow seems to
> cause it's fair share of puzzles.  I'd be suspicious of optimisation
> problems.  Looking at the somewhat old installation on this box, login
> links against libmisc and libshadow which both come from shadow, plus
> libcrypt and libc which come from from glibc.
> 
>  If you can't find any informative messages in the logs, maybe try
> rebuilding shadow without optimisation (and rerun whichever of pwconv
> and grpconv you intend to use, then rerun passwd root).
> 
> > As a side point, where do I set defaults. For example, I noticed that
> > when I su -, the path is quite weird and doesn't include the /sbin and
> > /usr/sbin directories. Is there somewhere I can change defaults
> > without using ~/.bashrc?
> >
> 
>  Sounds like a BLFS question :)  See chapter 3 of the BLFS book,
> probably the section Configuring for Adding Users.  Meanwhile, I suppose
> fix the PATH in /root/.bash_profile, although on a box of mine that's
> running 5.1-pre root's PATH is fine and it isn't obvious to me where
> it's coming from.
> 
> Ken
> -- 
>  das eine Mal als Tragödie, das andere Mal als Farce
> 
> --
> http://linuxfromscratch.org/mailman/listinfo/lfs-support
> FAQ: http://www.linuxfromscratch.org/lfs/faq.html
> Unsubscribe: See the above information page
> 

1




More information about the lfs-support mailing list