bug in autoconf

Ken Moffat ken at kenmoffat.uklinux.net
Sun Apr 4 15:33:26 PDT 2004


On Sun, 4 Apr 2004, Ruben Lopez wrote:

> >
> > > Here is my latest error in my attempt to get past LFS 51pre1 chp.5. I
> > > can compile glibc-2.3.3-20031202, but when I try to make the package I
> > > cannot get past this error:
> > >
> > > autoconf  sysdeps/i386/elf/configure.in > sysdeps/i386/elf/configure.new
> > > autoconf: Undefined macros ***BUG in Autoconf--please report** AC_FD_MSG
> > > make[1] *** [sysdeps/i386/elf/configure] Error 1 make[1]: Leaving
> > > directory '/lfs/sources/glibc-2.3.3-20021202' make: [all] Error 2
> > >
> > > I'm not even sure where to start looking for this one - I searched
> > > LFS.org archives but couldn't find anything helpful... coulld someone
> > > help me with this?
> > I had the same problem, upgrading to a newer autoconf version (2.13 in my
> > case to some 2.5x now) helped.
>
> Thanks for the hint, but my autoconf is already at 2.5x and I am still
> getting that error.
>

 Ah, I'd hoped that would fix it for you.  I'm not very well versed in
glibc configuration, but usually autoconf only gets run if something has
changed.  A quick look at some of my logs on ppc and i586 shows
configure checking for autoconf, and checking to see if it works, but
not using it.

 I think this was your second attempt on glibc, based on a permissions
problem you asked about. Please remove both the source directory and the
build directory before retrying, it's possible something you did manage
to build in your first attempt has broken the dependency-tracking.

Ken
-- 
 das eine Mal als Tragödie, das andere Mal als Farce




More information about the lfs-support mailing list