Normal user can't list vfat mount point

Cynthia Higginbotham cyhiggin at republicofnewhome.org
Thu Apr 1 09:28:09 PST 2004


On Wednesday 31 March 2004 11:02 pm, Tran Ngoc Hieu wrote:
> Here is my problem:
> Before mounting vfat partition (umask 022 for root, 002 for users):
>
> [root at localhost: root]# ls -l /mnt
> total 8
> drwxr-xr-x    2 root     root         4096 Mar 31 14:25 cdrom
> drwxr-xr-x    2 root     root         4096 Apr  1 02:20 hdd4
>
> And after mounting:
>
> [root at localhost: root]# mount -t vfat /dev/hdb6 /mnt/hd4
> [root at localhost: root]# ls -l /mnt
> total 12
> drwxr-xr-x    2 root     root         4096 Mar 31 14:25 cdrom
> drwxr--r--    5 root     root         8192 Jan  1  1970 hdd4
>
> Permissions on /mnt/hd4 change to rwxr--r--, and the time is Jan 1 1970
> (what!!!). I tried with

Yes, that's about what my /windows/C partition looks like when I mount it as 
user. However, in spite of those bizarre permissions, I can read and see the 
whole partition. Have you tried 'ls' on a directory in that partition?

> Did I forgot some options while configuring kenel so that it prevent normal
> users from viewing vfat
> partitions? (writing is possible as root) I'm really confused. Please
> someone help me out!

Have you tried just 'cd' to some directory in that partition and 'ls' to see 
if you really can't read it?  I have a similar setup in my windows partition, 
with the same permissions, and I can read it just fine.

-- 
-----------
Cynthia Higginbotham     cyhiggin at republicofnewhome dot org



More information about the lfs-support mailing list