Stalled on binutils

Ruben Lopez rl4 at rkcc.net
Thu Apr 1 08:29:34 PST 2004


> > 
> > I am trying to get past the binutils configuration in Chp. 5 of
> > LFS5.1pre1, and I have tried to build version 2.15.90.0.1, 2.14.90.0.7
> > (with patch) and 2.14, and I am getting a similar error with each try:
> 
> First off, why are you trying to use the HJL Binutils fork?  As we say on
> IRC - follow book, book good! - meaning use the version specified in the
> LFS book, in the case of 5.1pre1, it's GNU/FSF Binutils 2.14 from
> http://ftp.gnu.org/gnu/binutils

Thanks for your response...

I had wanted to start off using LFS hints 5.0+, so I had first tried to
configure the HJL binuilts. When that didn't work, I tried the other
versions.

> > 
> > (config.log)

<snip>

> > /lib/cpp  conftest.c >/dev/null 2>conftest.out configure:1370:
> > sys/file.h: No such file or directory configure: failed program was:
> > #line 1369 "configure" #include "confdefs.h" #include <sys/file.h>
> > 
> > Since I am seeing this with every version ofr binutils I assume that I
> > have missed a setting, although I followed and double-checked the
> > environmental settings. My host is Debian woody r1. Can someone point me
> > in the right direction to correct this error?
> 
> Looks like you are missing some development headers on Debian (I'm
> assuming this is Chapter 5 pass 1 of binutils) - but not sure which
> package would have file.h.

Hmmm... I installed gcc with woody, so I assumed that all of the files would
be there. I'l have to check this out.

> 
> Also, if you insist on using the HJL binutils fork, you'll need to add in
> the m4, bison, and flex packages for chapter 5, prefixed to /tools - HJL
> Binutils will require them come chapter 6, and you won't have access to
> your host then.

Thanks.

 
--
Ruben

"Vulcans never bluff."



More information about the lfs-support mailing list