problems with util-linux-2.12 in LFS 5.0 chapter 5 on sparc server

Dennis Clarke dclarke at blastwave.org
Thu Nov 27 04:18:53 PST 2003


> full details are at : http://www.blastwave.org/dclarke/linux/util-linux.log

> Any attempt to ./configure results in bogus messages about headers not being
> found .. even though the headers are in /tools/include :

Thank you Ken for the reply.  No joy yet though.

The first thing I suspected was the bad sed command suspect but then I simply
used vi and searched the configure file myself for bad /usr/include strings.

Even though my sed command looked good, and I tried it over and over with a
clean util-linux directory, the configure fails every time complaining about
the absence of the headers.  The first error is with the absence of
scsi/scsi.h which is in fact at /tools/include just fine.

Everything looks good but still no headers found.

I will now try a manual test with a conftest.c that specifies #include
<scsi/scsi.h> and see what gcc says.  This could all be a gcc problem.


Dennis




More information about the lfs-support mailing list