Module compilation breaks

weasel weasel at beyondnormal.org
Tue Nov 25 09:07:15 PST 2003


Alexander E. Patrakov wrote:
> On Tuesday 25 November 2003 20:59, Brian Beesley wrote:
> 
>>Hi,
>>
>>I'm failing to compile modules during the (LFS 5.0) kernel build stage :-(
>>
>>The failure is a compilation error in the aic7xxx module, which
>>unfortunately my system will require.
>>
>>(a) Is this a known problem, if so is there a fix?
> 
> 
> Yes, it is a known problem. At least I reproduced it. The error message says 
> that you need to install some version of Berkeley DB library (see the BLFS 
> book) before compiling the kernel because aicasm uses it. Do that and report 
> the results.
> 
ack, some part of the kernel depend on a outside package?  I can't 
believe that would get past the kernel dev team.....are you sure?!

Nick




More information about the lfs-support mailing list