Module compilation breaks

Kevin P. Fleming kpfleming at linuxfromscratch.org
Tue Nov 25 08:32:02 PST 2003


Alexander E. Patrakov wrote:
> Yes, it is a known problem. At least I reproduced it. The error message says 
> that you need to install some version of Berkeley DB library (see the BLFS 
> book) before compiling the kernel because aicasm uses it. Do that and report 
> the results.

aicasm shouldn't be used unless you are telling the kernel config that 
you want it to rebuild the aic7xxx firmware, and there's no reason for 
you to do that (the firmware files distributed in the kernel tarball 
should be fine). There's no way the standard kernel sources require any 
non-standard tools just to build the kernel, that would never get past 
Linus or Marcelo.




More information about the lfs-support mailing list