Issues with ld: "bootstrap with --static" rearing its ugly head

Erik Postma epostma at nl.tue.win
Sun Nov 23 10:18:12 PST 2003


On Sun, 23 Nov 2003 23:51:22 +1100, Greg Schafer <gschafer at zip.com.au>
wrote:
> On Sat, Nov 22, 2003 at 10:36:52PM +0100, Erik Postma wrote:
> > > > I'd just like to say I did start over, using the --disable-nls
> > > > flag in chapter 5 (not in 6) and it's working fine now. Greg, if
> > > > you'd like to have a .tar.bz2 from me too (in case you can't find
> > > > it from Stephen's stuff alone), I'll gladly prepare it but I don't
> > > > have time for it now. Gimme a week or so. I'm adding some specs of
> > > > my host system for Stephen to compare to his. If many things are
> > > > the same it might give a hint. I'm not at my machine right now,
> > > > but am fairly confident this is correct.
> 
> I couldn't find anything wrong with Stephen's files. But he wasn't
> seeing the binutils test suite failure like you were. He was seeing the
> other failure inside the chroot.
> 
> If you are still able to reproduce the problem, please follow the
> instructions here (exactly):
> 
> http://linuxfromscratch.org/pipermail/lfs-support/2003-November/020823.html
> 
> and mail it to me and I'll take a look.

Well, I do still have the host system... I guess this means I'd have to
redo binutils-p1, gcc-p1, linux-headers, glibc, lock-in, tcl, expect,
dejagnu, gcc-p2 and binutils-p2, right?

-- 
Erik Postma (Email: reverse the order of nl, tue and win.)



More information about the lfs-support mailing list