I forgot to keep BINUTILS second stage

Greg Schafer gschafer at zip.com.au
Tue Nov 18 16:44:45 PST 2003


On Tue, Nov 18, 2003 at 06:52:02PM +0100, llista wrote:
> I've make a mistake andi want to know until my system have been lost.  I 
> explain...
> 
> When I compile GLIBC 2.3.2 in chroot mode, evething  woked well and make 
> check didn't get any error. I installed locals y were well too. The 
> problem appeared whren i was going to ajust the tools with the BINUTILS 
> stored in stage 2. I realized that it were been erased.

This is not a fatal problem. The book deals with the issue and gives exact
instructions on what do i.e. nothing :-)

> Then i saw that book told that it wasn't necessary to keep the BINUTILS 
> stage 2 stored. so i remembered that my glibc compilation worked well, I 
> tried to perform the dummy test
> 
> now I perform    gcc dummy.c and the shell doesn't answer me..
> 
> Somebody can tell me I have make a tragedy???

No. You should be able to easily recover.

> I have to reinstall everithig<????
> 
> Can I rescue anything???  so.. where I must re start my compilation 
> from?????

If the last successful thing you did was compile glibc in Ch 6, the solution
is easy. Just move on to the "adjusting toolchain section", skip the
adjusted linker part, but do perform the GCC specs amendment. After this,
perform the sanity check and assuming it's good, carry on with binutils,
gcc, etc.



More information about the lfs-support mailing list