I forgot to keep BINUTILS second stage

llista llista at ya.com
Tue Nov 18 09:52:02 PST 2003


Hi,

I've make a mistake andi want to know until my system have been lost.  I 
explain...

When I compile GLIBC 2.3.2 in chroot mode, evething  woked well and make 
check didn't get any error. I installed locals y were well too. The 
problem appeared whren i was going to ajust the tools with the BINUTILS 
stored in stage 2. I realized that it were been erased.

In addition, i made a second mitake...  that was to open a new terminal 
(without chroot mode) and configure and compile binutils like in stage 2 
.  This compilations failed. I didn't intalled them..

Then i tried  to re enter in chroot mode and perform   make -C ld 
INSTALL=/tools/bin/install install   ( as in the book says) and i didn't 
reach it  :(   it failed

Then i saw that book told that it wasn't necessary to keep the BINUTILS 
stage 2 stored. so i remembered that my glibc compilation worked well, I 
tried to perform the dummy test

now I perform    gcc dummy.c and the shell doesn't answer me..

Somebody can tell me I have make a tragedy?¿?

I have to reinstall everithig<????

Can I rescue anything?¿?  so.. where I must re start my compilation 
from¿?¿??

Thanks in advanced  :)

PD: Sorry about my english




More information about the lfs-support mailing list