glibc-2.3.2 (Chapter 5) is confused by earlier errors

Brett lfs at brettscaife.org
Tue Nov 18 02:04:26 PST 2003


> On Mon, 17 Nov 2003 08:53:27 +1100
> Greg Schafer <gschafer at zip.com.au> wrote:

> 1. If this is your first LFS, you should be sticking to the exact
> versions in the book.

I tried gcc-3.3.2 after a couple of failures with gcc-3.3.1. Clearly, it didn't do me any good as I got exactly the same errors with both

> 
> 2. You shouldn't be scripting your builds. Who knows what
> environmental variations you have introduced into the equation
> by doing this? Please go exactly by the book for now.

I only went for scripts after my third failure. I got sick of typing in the same things over and over again. I don't think the scripts are causing the problem as I get the same error at the same stage each time.
I've followed your advice and gone throught he whole process so far using exactly the versions cited in the book and typing in the instructions as wriiten there.

> 
> 3. As per the "How to ask for help" section of the book, you haven't
> posted enough information, especially the host distro details.

My host system is sort-of Slackware 8.1 - it started out as this but I'm afraid I've fiddled with it a lot, including upgrading GCC to 3.3.2 and upgrading the kernel to 2.4.22

> 
> 4. The problematic file appears to be
>    "/home/lfs/glibc-build/csu/version-info.h". Please post the
>    contents of that file so we can see what's up with it.

This is version-info.h after going through the book as instructed:

----------

"Compiled on a Linux 2.4.22 system on 2003-11-18.
"
"Available extensions:
"
"	GNU libio by Per Bothner\n"
"	crypt add-on version 2.1 by Michael Glad and others\n"
"	linuxthreads-0.9 by Xavier Leroy\n"
"	BIND-8.2.3-T5B\n"
"	libthread_db work sponsored by Alpha Processor Inc\n"
"	NIS(YP)/NIS+ NSS modules 0.19 by Thorsten Kukuk\n"

----------

Hope this is enough info, thanks for your time,

Brett



More information about the lfs-support mailing list