chapter 5 gettext-0.12.1 failures

Erik Postma epostma at nl.tue.win
Fri Nov 14 07:46:56 PST 2003


On Fri, 14 Nov 2003 09:23:06 -0600, "Ray, TD Travis (8878) @ IS"
<Travis.D.Ray at L-3com.com> wrote:
> Hi.
> 
> 	I'm having problems with ch5 gettext and I'm hoping one of you
> 	will
> be
> able to point out what I seem to have missed.  I'm not at my target
> system right now so I apologize for the lack of an actual log.  I'll
> attempt to recall from memory the best I can.
> 
>     The first error occurred while compiling
>     'gettext-tools/src/msginit.c'.
> It was expecting to find 'localename.lo' at '../intl/localename.lo' 
> (that would be 'gettext-tools/intl/localename.lo' in the source tree).
> So, I went hunting and found it at
> '../../gettext-runtime/intl/localename.lo'
> (that would be 'gettext-runtime/intl/localename.lo' in the source tree).
> 
>     I hacked the Makefile and changed the reference to get past that
>     point,
> soon after my lack of confidence in its overall success was validated. 
> The next series of problems were essentially the same as above but the
> files that
> could not be found were libgnuintl.{h,la,so}.  Guess where they are at? 
> In a subdirectory of 'gettext-runtime' *not* 'gettext-tools'.  Another
> oddity 
> concerning this series of failures is that they occurred while compiling
> the sources in the 'tests' subdirectory.  I did not run 'make check'. 
> All errors 
> occurred during 'make'.
> 
>     It appears to me that gettext is being misconfigured somehow,
>     although I
> cannot for the life of me figure out how.  I'm using the book
> instructions, and I've verified that the environment is as specified in
> 'Setting up the environment'.  I can prop it up enough to continue, but
> I hesitate to do that.
> What concerns me most is the fact that I've read of no-one else having
> these
> 
> difficulties on this list, so I'm inclined to believe I've screwed up 
> somewhere upstream.  Does anyone have a clue how or where?
> 
> Thanks!
> 
> BTW: Host distribution is slackware-9.0
> 

I'm aware that this sounds a bit haughty, but anyway. Have you deleted and
re-extracted your source tree after it went wrong and then tried again,
paying extra attention to the typing of all the options right? In my
experience some problems do get fixed by this, especially if no one else
has had them. Also double-check that the version number matches the one
from the book. And come back if it still doesn't work after that ;)

-- 
Erik Postma (Email: reverse the order of nl, tue and win.)



More information about the lfs-support mailing list