Booting LFS with init2

Miguel Brossolette mpbb at noos.fr
Wed Nov 12 08:02:01 PST 2003


Hi,

Wondered if anyone could help me on this:

I've just finished installed LFS 5.0 and a first test worked fine.

I've built my system on the same partition of my host sytem (following the 
"lfs-next-to-existing-systems" script)
note: i'm compiling kernel 2.5.75 i/o 2.4.22 on gcc 3.3.2 i/o 2.95.3
then  I went on cleaning my install (trashing /tools, moving sources to /usr/
src, including the linux kernel directory)

and then the system would not reboot with grub - "no init found"

i've tried to think what I've changed that could affect this, but haven't 
succeeded.
i've performed the following checks:
- grub still boots my old system ...
- grub will boot the lfs system if i replace init2 by init (so apparently this 
isn't  a mounting issue)
- checked if there was a problem with init2 executability, but apparently no
- even recompiled and reinstalled linux 2.5.75 but this doesn't seem the issue 
as it boots fine with init

Any idea anyone ?

Thanks in advance
-- 
Miguel P  B Branco




More information about the lfs-support mailing list