Init script nightmare.

Paul Campbell paul at multimedia-campbell.com
Wed Nov 12 03:23:17 PST 2003


I have spent the last 3 hours booting two systems after a power outage kill
them and they failed to boot.

Problem 1:
"Press any key to continue..."

Very good, if I had a keyboard attached to the system (makes mental note to
remove those `read` statments).

The rest of booting the server (an hour) was down to my fault not LFS. 
Apparently, even though I test booted and test booted again, this time,
rpc.mountd decided it needed DNS and Bind to be running before it would let
boot proceed.  This might be connected to MySQL and the msyslogd logger. 
That sorted and on to the firewall, which also hadn't booted past post....

Good old Compaq eh?  Dont ya love em?  Great cases, shit sense.  It was
saying....

"No Keyboard present."  
"Press F1 to boot".

No option in BIOS to disable it.  No "Halt on all but keyboard"  nothing. 
So stuck with a keyboard in it.

Problem 2:
I changed a SCSI disk on my firewall (an Aux drive, NOT required to boot and
empty) to be ext3 in fstab, but.... silly me, forgot to run tune2fs on it. 
Why was this a problem?  I asked the same question.  LFS init scripts?
Well they thought it was the brightest plan in the world to ....

Your system will be halted...
Press any key to continue...

OK I thought, edit the grub command line and bring her up in single user
mode.

LFS said....
Your system will be halted...
Press any key to continue...

Need I say..  "GRRRRRRRRRR!!!!!!!!!!!!!!!!!!!!!!"  "I know, lets call "halt"
in rc.sysinit why dont we, that will really fuck the admin off when things
go wrong, isn't that bright?"  No!

If you wrote that piece of init script code, you are VERY lucky you were
hundreds of miles away this morning.  I would have stuff the IEC cable up
your...

I tried boot with rescuix, no ext3 support.  I tried booting from the MDK
install CD... not enough memory for the ram disk, SCSI and IDE modules.  On
32Mb believe it or not.

I went out to buy some CD/RWs on a mission to make a boot disk once and for
all.  Then I realised that...  Well.  I needed to net didn't I and with the
router/firewall screaming like a baby and halting itself on boot when it
can't mount a NON IMPORTANT drive, I was shafted.

In the end, I took out the drive from the firewall, stuffed it into my
workstation and booted.

Were the probs over.... nope.

hdc: driver no present.

Damn old Caviar drives, ATA (either wrong ident or very very OLD ATA).

I finally sorted it by booting the MDK CD from the workstation and mounting
the drive there, deleting the fstab entry for the ext2 (should be ext3)
partition... then removing ALL references to halt, reboot and read from the
init scripts.

Im sorry to whine about them, but that damn (would use a sttonger word),
`read` statement is a curse, always gets in the way.  Server dies in power
brown out and 10 minutes later, when I wonder why it hasn't booted up, I do
the whole rull the rack out from the wall, contort in behind it, get
electricuted by the mental monitor plug, find the maintenance keyboard and
connect it up, to see it say "Press any key to continue..."  like it's some
form of damned ZX81 game!  Thoughts of.... it's a good job I am local and
dont have to drive 100 miles to the server.

I would like to make a suggestion?  Point these problems out.  If you are
installing LFS on a basic singular desktop, they are fine, if you
installing anything else that has to make it's very best efforts to come up
in whatever state, they are a liability.

At worst you/I/someone could add:

STOP_ON_FAIL=
REBOOT_ON_FAIL=
HALT_ON_FAIL=

So that they can be turned off in $rc_base/function


</rant>


BFN
Paul



More information about the lfs-support mailing list