glibc, ch5, p1: error compiling libc.so.6

Erik Postma epostma at nl.tue.win
Tue Nov 11 07:16:09 PST 2003


On Tue, 11 Nov 2003 15:48:55 +0100, Jappie <jappie at tiscalimail.nl> wrote:
> The error was probably due to the fact that I didn"t run the command 
> "make -C ld install". This because I"ve build a script witch cd"ed into 
> a nonexisting directory, and the line never gets started.
> I fixed that... So the dummy.c gets compiled without errors.
> 
> But when I run the line "readelf -l a.out | grep ': /tools'" I get no
> output When I run the line "readelf -l a.out | grep ': /lib'" I get the
> output: "[Requesting program interpreter: /lib/ld-linux.so.2]"
> 
> So the linker still points to /lib/ld-linux.so.2 in stead of 
> /tools/ld-linux.so.2
> Where am I doing something wrong ?
> 
> I"d realy like some help thistime, it"s quite frustrating having to 
> begin over and over again with no clue what you"re doing wrong.
> Jappie

This suggests that the "adapting of the specs file" went wrong. Please
make sure that your specs file is correctly adjusted; i.e. 
  grep /tools/lib/ld-linux.so.2 name-of-specs-file 
should return a long long line. If it returns no line, please reapply the
sed script to it.

> > source-system: lfs-4.0
> > lfs: 5.0
> > gcc: 3.2
> > glibc: 2.2.5
What do you mean by this? Are you doing lfs5.0 but with older versions of
gcc and glibc? Or are these the versions from your source system?

-- 
Erik Postma (Email: reverse the order of nl, tue and win.)



More information about the lfs-support mailing list