VIA Rhine network card problem

Erik Postma epostma at nl.tue.win
Tue Nov 11 04:49:37 PST 2003


On Tue, 11 Nov 2003 00:45:04 +0100, "Justin Knierim" <lfs at jrknierim.de>
wrote:
> Hello everyone,
> 
> I have been trying the last day or so to get a LFS 5.0 system setup on a
> server.  I have been doing everything through a SSH window, and so far,
> everything has worked.  The system even boots, and gets past network
> setup, but the network card does not get configured
> (ifconfig/ifup/standard lfs network boot script), and so SSH starts and
> gives an error with cannot connect 0.0.0.0, and I cannot ssh in.  So,
> luckily there is a nice recovery system at the host, so I can see the
> damage and investigate...
> 
> The network card is a VIA Rhine-II, VT6102.  The host system, Suse 8.1,
> the card worked.  Not a module, compiled in.  
> 
> <from /proc/pci>
> Bus  0, device  18, function  0:
>     Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev
> 116).
>       IRQ 23.
>       Master Capable.  Latency=32.  Min Gnt=3.Max Lat=8.
>       I/O at 0xe000 [0xe0ff].
>       Non-prefetchable 32 bit memory at 0xea401000 [0xea4010ff].
> 
> The kernel finds the card, no problems...
> 
> I can put the whole log online if anyone wants.  All other log files are
> empty, or have the same as kern.log, except auth.log, there it tells:
> 
> Nov 11 00:11:13 p1514xxxx sshd[101]: Server listening on :: port 22.
> Nov 11 00:11:13 p1514xxxx sshd[101]: error: Bind to port 22 on 0.0.0.0
> failed: Address already in use.
> 
> IPv6 should not be a problem, I do not have the protocol enabled in the
> kernel, and do not want/use it.  So, it finds the card, it has irq 23
> (suse shows the same thing).  I started the system a few times with it
> recording everything to a log file that I could.  And lo gets setup, but
> not eth0.  I tried various ifconfig/ifup commands, and tried to log them
> also, but could not get any output.  I will try to capture the return
> codes next, maybe this might help.  :-/  The /etc/hosts and
> /etc/sysconfig/network-devices/ifconfig.eth0 are setup correctly (I have
> built many lfs systems, so I know a bit about this at least :)), and
> even running directly the ifconfig eth0 IP..., it does not work.
> 
> So, can anyone tell me how to get this thing working??  This server is
> on a fixed IP, should be nice and simple I thought.  And help would be
> appreciated!  It is probably something obvious or stupid I did!  ;)
> 

Is there any way you can go there physically and see what ifconfig says
after you've booted it?

-- 
Erik Postma (Email: reverse the order of nl, tue and win.)



More information about the lfs-support mailing list