Grub Issues

Kevin Alm kevinalm at shenessex.heartland.net
Wed Nov 5 14:08:51 PST 2003


Brant Langer Gurganus wrote:

> Benjamin Gehrels wrote:
>
>> "Brant Langer Gurganus" <gurganbl at rose-hulman.edu> schrieb im 
>> Newsbeitrag
>> news:bob7lg$ta2$1 at belgarath.linuxfromscratch.org...
>>
>>> I have tried looking for an answer at Grub's site and in the LFS lists
>>> as well as in general Google searches and couldn't find my specific
>>> issue.  My bootloader would hang during stage 1.5.  I am sure my Grub
>>> entries were correct because that is the entry that grub gave when I
>>> used find().  /dev/hda2 is hd(0,1) to Grub.  It would still hang 
>>> though.
>>>  It was an ext3 file system which, in theory, should be compatible with
>>> ext2 file system that was configured in Grub.  Lilo works though.
>>>
>>> The best answer I could come up with is that my hardware is too new for
>>> Grub.  Any ideas?
>>
>
> There is no error, it just hangs.
> As for APM=off, I need to keep it on since ACPI support for my laptop 
> is not complete (even with latest patches) so not everything works.
>
Have you tried compiling in ext3 support ? Not as a module. If you 
compile support for your primary filesystem as a module then you must 
also create an initrd.img.





More information about the lfs-support mailing list