problem in glibc-2.3.2 locales (LFS-5.0-pre, Ch6)

Ken Moffat ken at kenmoffat.uklinux.net
Sat Nov 1 10:56:39 PST 2003


 Well, today must be my day for scripting errors.  I accidentally
reversed the sense of a test, causing my build to attempt to install
_only_ the minimal locales, and boom!

(lines wrapped, copied by hand)
/usr/share/i18n/locales/es_MX:26: LC_IDENTIFICATION: unknown character
in field `address'
/usr/share/i18n/locales/es_MX:89: LC_TIME: unknown character in field
`abday'

  another three similar lines, then

no output file produced because warning were issued

 I think I saw something like this on lfs-dev a few weeks ago, which
appeared to be related to use of the host's localedef (in ch5), but
anyway running locale/localedef -i es_MX -f ISO8859-1 es_MX gives the
same error (I guess localedef was already installed).

 However, if I run make localedata/install-locales it finishes normally
and using 'more' to look at the es_MX locale shows the following on line
26 (again, wrapped) :

address    "Sankt J<U00F8>rgens Alle 8, DK-1615 K<U00F8>benhavn V,
Danmark"


 I've looked at the other errors, but all the characters seem to be in
<U00nn> format, and I can't easily see if anything is odd.

 So, it seems to me that

(i) the installed locale contains non-ISO8859-1 or non-ASCII characters
which is _probably_ a technical error

and

(ii) if I install all locales this error is ignored, but if I try to
just install the necessary ones it hits me.

 Anybody else get this ?  Is my host (approx lfs-4.1) b0rken ?
Alternatively, is the "no output file" message lying, meaning that my
'&&' on these commands is the actual problem ? (They're all now
installed, so I can't tell whether it really installed es_MX the first
time and lied to me).

 Ken

 -- Will code payroll for food.






More information about the lfs-support mailing list