Problems with Groff-1.18

Greg Schafer gschafer at zip.com.au
Fri Jan 31 15:15:28 PST 2003


On Fri, Jan 31, 2003 at 03:48:11AM -0600, Roy M. Ens wrote:
> I'm using the CVS version of the LFS book and got to installing groff.
> I've searched the archives and haven't found anything relating to the
> problem that I'm having. I'm using the "More control and package
> managemnt with package users" hint as package management. I fear that
> this might be causing the problem but I'm not sure. Any help would be
> appreciated.
> 
> I believe only some of the documentation is not compiling but I could be
> wrong. Here is the last few lines of output when running make.
> 
> <standard input>:35: `gnu.eps' is empty
> /bin/sh: xpmtoppm: command not found
> /bin/sh: pnmdepth: command not found
> /bin/sh: pnmtopng: command not found
> make[2]: *** [gnu.png] Error 127
> make[2]: Leaving directory `/usr/src/groff/groff-1.18/doc'
> make[1]: *** [doc] Error 2
> make[1]: Leaving directory `/usr/src/groff/groff-1.18'
> make: *** [all] Error 2

LFS 4.0 right? Looks like you made a typo. The important bits are the
PROCESSEDEXAMPLEFILES= thing

make PROCESSEDEXAMPLEFILES="" &&
make PROCESSEDEXAMPLEFILES="" install &&

Newer groff-1.18.1 fixes the bug and doesn't need the workaround.

Greg
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list