Problem compiling glibc-2.2.5

Chris Lingard chris at stockwith.co.uk
Tue Jan 28 08:57:11 PST 2003


Lokhorst wrote:

> When i'm compiling glibc in chaper 6, I get this error:
> 
> ../sysdeps/unix/sysv/linux/errlist.c:41: weak declaration of
> `_old_sys_nerr' must preced definition
> make[2]: *** [/usr/src/glibc-build/stdio-common/errlist.os] Error 1
> make[2]: leaving directory `/usr/src/glibc-2.2.5/stdio-common'
> make[1] *** [stdio-common/subdir_lib] Error 2
> make[1] Leaving directory `/usr/src/glibc-2.2.5'
> make: *** [all] Error 2
> 
> What did i do wrong?
> 
You have missed a patch.  Did you download your source and patches
from LFS?  Perhaps your base system uses gcc 3

See http://www.zipworld.com.au/~gschafer/lfs-tweaks.html


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list