Kernel headers installation problem

dsnpa dsnpa at yandex.ru
Mon Jan 27 03:19:31 PST 2003


Hi!
I have a problems at the stage of installing kernel headers
(described in chapter 6). When I type `make mrproper` in kernel
sources' directory, I have a following messages:

# make mrproper
/bin/sh: /dev/null: Permission denied
make[1]: Entering directory `/usr/src/lfs/lfs-packages-4.0/linux-2.4.19/arch/i386/boot'
rm -f tools/build
rm -f setup bootsect zImage compressed/vmlinux.out
rm -f bsetup bbootsect bzImage compressed/bvmlinux.out
make[2]: Entering directory `/usr/src/lfs/lfs-packages-4.0/linux-2.4.19/arch/i386/boot/compressed'
rm -f vmlinux bvmlinux _tmp_*
make[2]: Leaving directory `/usr/src/lfs/lfs-packages-4.0/linux-2.4.19/arch/i386/boot/compressed'
make[1]: Leaving directory `/usr/src/lfs/lfs-packages-4.0/linux-2.4.19/arch/i386/boot'
find . \( -name '*.[oas]' -o -name core -o -name '.*.flags' \) -type f -print \
| grep -v lxdialog/ | xargs rm -f
/bin/sh: /static/bin/xargs: No such file or directory
/bin/sh: /static/bin/find: No such file or directory
make: *** [clean] Error 127

BTW, a messsage about /dev/null appeared also when I ran MAKEDEV
script. However /dev/null's permissions seems OK for me:

# ls -l /dev/null
crw-rw-rw-    1 0        0          1,   3 Jan 27 08:00 /dev/null

When I tried to execute `make include/linux/version.h` a following
messages appeared:

# make include/linux/version.h
/bin/sh: /dev/null: Permission denied
/bin/sh: /dev/null: Permission denied
KERNELRELEASE "2.4.19" exceeds 64 characters
make: *** [include/linux/version.h] Error 1

Can anybody help me with this?

Regards, Dmitry Samoyloff

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list