glibc patch problem (fwd)

Manuel Vázquez Acosta manu at chasqui.cu
Sat Jan 18 12:49:36 PST 2003


Hi again:

(I'm not a member of the list; please answer directly to me.)

In regards to linuxthreads I did exactly as the book says.

About the patch, since I ran:
  patch -Np1 -I ../glibc.patch && ... && ...
This is, every command but the last followed by &&. 
I think if patch would have returned an error code it'd not compiled at all, but it did.

About logs, I very new in linux and I don't where to find them, but in /var/log there's nothing.

Now, util−linux−2.11u also gave me the same error I watched the config.h which include the autoconf.h file.

I ran: touch /usr/include/linux/autoconf.h
And compiled again lilo, sysklogd and utils-linux and they gave me no errors. But I can't be sure they'll work fine. Any hints?

Manu.

-----Original Message-----
From: Bill's LFS Login [mailto:lfsbill at wlmcs.com] 
Sent: Saturday, January 18, 2003 12:22 PM
To: [iso-8859-1] Manuel Vzquez Acosta
Subject: Re: glibc patch problem (fwd)

I forgot to forward this to you on my first reply. Sorry.

-- 
Bill Maltby
lfsbill at wlmcs.com

---------- Forwarded message ----------
Date: Sat, 18 Jan 2003 11:42:31 -0500 (EST)
From: Bill's LFS Login <lfsbill at wlmcs.com>
To: lfs-support at linuxfromscratch.org
Subject: Re: glibc patch problem

On Sat, 18 Jan 2003, willem wrote:

> Hi,
>
> In the middle of building LFS.
> When i try to patch glibc i get the following(pasted below)
> as described in page 69 of the 4 manual.
> What to do now?
>
> Cheers,
> Willem
>
> I have no name!:/static/src/tarbals# cd glibc-2.2.5
> <s/glibc-2.2.5# patch -Np1 -i ../glibc-2.2.5-2.patch
> patching file login/Makefile
> patching file malloc/Makefile
> patching file iconv/skeleton.c
> can't find file to patch at input line 83
> Perhaps you used the wrong -p or --strip option?
> The text leading up to this was:
> --------------------------
> |diff -uNr glibc-2.2.5.orig/linuxthreads/signals.c
> glibc-2.2.5/linuxthreads/signals.c
> |--- glibc-2.2.5.orig/linuxthreads/signals.c    2002-01-21
> 14:21:16.000000000 +1100
> |+++ glibc-2.2.5/linuxthreads/signals.c 2002-08-10 09:24:57.000000000 +1000
> --------------------------
> File to patch:

Did you remember to untar the linuxthreads *inside* glibc directory as the
book instructs?

-- 
Bill Maltby
lfsbill at wlmcs.com




-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-support' in the subject header of the message



More information about the lfs-support mailing list